Hướng Dẫn Fix Lỗi Fatal Error: Cannot Break 2 Levels Widget Framework Xenforo

Thảo luận trong 'Mã Nguồn' bắt đầu bởi Pussy, Thg 6 25, 2018.

  1. Pussy

    Pussy New Member

    Tham gia ngày:
    Thg 3 21, 2016
    Bài viết:
    516
    Xem: 145
    Nếu bạn cảm thấy hay, hãy chia sẻ để ủng hộ tác giả, xin cám ơn
    Lỗi : Fatal error: Cannot 'break' 2 levels in /public_html/library/WidgetFramework/Helper/Index.php on line 90

    Lỗi này do mod Widget Framework không tương thích với PHP phiên bản 7.0

    Các bạn có 2 cách fix

    1. Chọn PHP phiên bản thấp hơn: 5.6

    2. Mở file Index đó lên tìm ở dòng thứ 90

    Mã:
    if (!$selected)
                {
                    // still not selected!?
                    // try with $extraTabs now
                    foreach ($extraTabs as &$tabs)
                    {
                        $tab['selected'] = true;
                        $selected = true;
                        break 2;// <<<<<<<<<<<<<<<<<<<
                    }
                }
    Thay break 2; bằng break;
     
    Last edited by a moderator: Thg 6 26, 2018
  2. Đang tải...
Trả lời qua Facebook

Chia sẻ trang này